summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-04-23 15:55:31 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-01 01:21:04 +0200
commit135c1e0e433edc8258b1a7d018258e3ef5919122 (patch)
treecbef235b1100d20175ca920d988f459ff6ebab25
parent524e5fe56b602d2ccb1dd2bf5a50a0e6ca397759 (diff)
downloadpatches-135c1e0e433edc8258b1a7d018258e3ef5919122.tar
patches-135c1e0e433edc8258b1a7d018258e3ef5919122.tar.gz
gnu: umockdev: Fix test.
* gnu/packages/check.scm (umockdev)[inputs]: Remove 'gobject-introspection'. [arguments]: Replace phase 'skip-broken-test' by 'fix-test'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/check.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5f3073d556..427607e6de 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2436,11 +2437,10 @@ provides a simple way to achieve this.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-broken-test
+ (add-after 'unpack 'fix-test
(lambda _
(substitute* "tests/test-umockdev.c"
- (("/\\* sys/ in other dir")
- (string-append "return; // ")))
+ (("/run") "/tmp"))
#t)))))
(native-inputs
`(("vala" ,vala)
@@ -2453,8 +2453,7 @@ provides a simple way to achieve this.")
(inputs
`(("glib" ,glib)
("eudev" ,eudev)
- ("libgudev" ,libgudev)
- ("gobject-introspection" ,gobject-introspection)))
+ ("libgudev" ,libgudev)))
(home-page "https://github.com/martinpitt/umockdev/")
(synopsis "Mock hardware devices for creating unit tests")
(description "umockdev mocks hardware devices for creating integration