summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-30 15:30:16 +0200
committerRoel Janssen <roel@gnu.org>2020-04-30 15:30:16 +0200
commiteca648b65b51d1154363dd63dd602ebb9797d478 (patch)
treeea9eee16b80d3c3809d0e5439b63d068243500a6
parente17423186323829dff925d2f0fdbd8f494206a6e (diff)
downloadpatches-eca648b65b51d1154363dd63dd602ebb9797d478.tar
patches-eca648b65b51d1154363dd63dd602ebb9797d478.tar.gz
gnu: Add miniasm.
* gnu/packages/bioinformatics.scm (miniasm): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 740ed66972..65b44568e0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13312,6 +13312,42 @@ cases include:
@end enumerate\n")
(license license:expat)))
+(define-public miniasm
+ (package
+ (name "miniasm")
+ (version "0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lh3/miniasm/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g89pa98dvh34idv7w1zv12bsbyr3a11c4qb1cdcz68gyda88s4v"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "miniasm" bin)
+ (install-file "minidot" bin)))))))
+ (home-page "https://github.com/lh3/miniasm")
+ (synopsis "Ultrafast de novo assembly for long noisy reads")
+ (description "Miniasm is a very fast OLC-based de novo assembler for noisy
+long reads. It takes all-vs-all read self-mappings (typically by minimap) as
+input and outputs an assembly graph in the GFA format. Different from
+mainstream assemblers, miniasm does not have a consensus step. It simply
+concatenates pieces of read sequences to generate the final unitig sequences.
+Thus the per-base error rate is similar to the raw input reads.")
+ (license license:expat)))
+
(define-public r-circus
(package
(name "r-circus")