summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-30 13:06:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-30 13:08:33 +0200
commitcf1ae793753e9da0d774f4a5495648f15d400b49 (patch)
treec1a630438f08ebe98e9de632253bace209c38d00
parent46d07f8472f09813be287fa5a10afb50c959dcb1 (diff)
downloadpatches-cf1ae793753e9da0d774f4a5495648f15d400b49.tar
patches-cf1ae793753e9da0d774f4a5495648f15d400b49.tar.gz
gnu: python2-pysnptools: Update to 0.4.11.
* gnu/packages/python-xyz.scm (python2-pysnptools): Update to 0.4.11; implement in terms of... (python-pysnptools): ...this new variable. [propagated-inputs]: Add python-dill, python-h5py, and python-psutil.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 24 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f4351d152..74280befea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4876,27 +4876,38 @@ toolkits.")
three-way Venn diagrams in @code{matplotlib}.")
(license license:expat)))
-(define-public python2-pysnptools
+(define-public python-pysnptools
(package
- (name "python2-pysnptools")
- (version "0.3.13")
+ (name "python-pysnptools")
+ (version "0.4.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pysnptools" version))
(sha256
(base32
- "0lnis5xsl7bi0hz4f7gbicahzi5zlxkc21nk3g374xv8fb5hb3qm"))))
+ "0gxr0bjix307wvk0qh7vkafbxbzfpdmq0wlswpxyyaymy0fwcypv"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; only Python 2.7 is supported
- #:tests? #f)) ; test files (e.g. examples/toydata.bim) not included
+ `(#:tests? #f ; no test data are included
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python3" "pysnptools/test.py"))
+ #t))))))
(propagated-inputs
- `(("python2-numpy" ,python2-numpy)
- ("python2-scipy" ,python2-scipy)
- ("python2-pandas" ,python2-pandas)))
+ `(("python-dill" ,python-dill)
+ ("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-psutil" ,python-psutil)
+ ("python-scipy" ,python-scipy)))
(native-inputs
- `(("python2-cython" ,python2-cython)))
+ `(("python-cython" ,python-cython)))
(home-page "http://microsoftgenomics.github.io/PySnpTools/")
(synopsis "Library for reading and manipulating genetic data")
(description
@@ -4906,6 +4917,9 @@ those files. It can also efficiently manipulate ranges of integers using set
operators such as union, intersection, and difference.")
(license license:asl2.0)))
+(define-public python2-pysnptools
+ (package-with-python2 python-pysnptools))
+
(define-public python-socksipy-branch
(package
(name "python-socksipy-branch")