summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-10 14:58:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-30 14:04:05 +0200
commit61fc72d3ac949d0c65690ee25bb1daf01f39bb42 (patch)
tree5fff57f4b2c7f4170e0e916e3b02d74098e8ffbe
parentcf1ae793753e9da0d774f4a5495648f15d400b49 (diff)
downloadpatches-61fc72d3ac949d0c65690ee25bb1daf01f39bb42.tar
patches-61fc72d3ac949d0c65690ee25bb1daf01f39bb42.tar.gz
gnu: Add zbackup.
* gnu/packages/backup.scm (zbackup): New variable.
-rw-r--r--gnu/packages/backup.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index d80359f8f1..23860ec821 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -976,6 +977,42 @@ precious backup space.
@end itemize")
(license license:bsd-2)))
+(define-public zbackup
+ (package
+ (name "zbackup")
+ (version "1.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zbackup/zbackup.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14l1kyxg7pccpax3d6qcpmdycb70kn3fxp1a59w64hqy2493hngl"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no test
+ (inputs
+ `(("lzo" ,lzo)
+ ("libressl" ,libressl)
+ ("protobuf" ,protobuf)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (home-page "http://zbackup.org")
+ (synopsis "Versatile deduplicating backup tool")
+ (description
+ "ZBackup is a globally-deduplicating backup tool, based on the
+ideas found in Rsync. Feed a large @file{.tar} into it, and it will
+store duplicate regions of it only once, then compress and optionally
+encrypt the result. Feed another @file{.tar} file, and it will also
+re-use any data found in any previous backups. This way only new
+changes are stored, and as long as the files are not very different,
+the amount of storage required is very low. Any of the backup files
+stored previously can be read back in full at any time. The program
+is format-agnostic, so you can feed virtually any files to it.")
+ (license license:gpl2+)))
+
(define-public burp
(package
(name "burp")