summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:16:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commit567bf5b975bdfda14a8f7aecb84dfa976208d6fa (patch)
tree099dbb71831d1c2e95e4ef5bd5ee3dce7bc68fda
parent613845d040429d79382448f68d2e5ed8f28c699f (diff)
downloadpatches-567bf5b975bdfda14a8f7aecb84dfa976208d6fa.tar
patches-567bf5b975bdfda14a8f7aecb84dfa976208d6fa.tar.gz
gnu: ghc-stm: Update to 2.4.5.0.
* gnu/packages/haskell.scm (ghc-stm): Update to 2.4.5.0. [description]: Improve.
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ba66e96053..b27185848b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1717,7 +1717,7 @@ access to the full zlib feature set.")
(define-public ghc-stm
(package
(name "ghc-stm")
- (version "2.4.4")
+ (version "2.4.5.0")
(outputs '("out" "doc"))
(source
(origin
@@ -1728,12 +1728,18 @@ access to the full zlib feature set.")
".tar.gz"))
(sha256
(base32
- "0gc8zvdijp3rwmidkpxv76b4i0dc8dw6nbd92rxl4vxl0655iysx"))))
+ "19sr11a0hqikhvf561b38phz6k3zg9s157a0f5ffvghk7wcdpmri"))))
(build-system haskell-build-system)
(home-page "https://hackage.haskell.org/package/stm")
(synopsis "Software Transactional Memory")
(description
- "A modular composable concurrency abstraction.")
+ "Software Transactional Memory, or STM, is an abstraction for concurrent
+communication. The main benefits of STM are composability and modularity.
+That is, using STM you can write concurrent abstractions that can be easily
+composed with any other abstraction built using STM, without exposing the
+details of how your abstraction ensures safety. This is typically not the
+case with other forms of concurrent communication, such as locks or
+@code{MVar}s.")
(license license:bsd-3)))
(define-public ghc-parallel