summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Note <jean-baptiste.note@m4x.org>2020-04-26 05:59:48 -0400
committerLudovic Courtès <ludo@gnu.org>2020-05-01 01:21:03 +0200
commit524e5fe56b602d2ccb1dd2bf5a50a0e6ca397759 (patch)
tree778bbeeef4b4f464afd852eb49e716a94146cb67
parent7ff2159b10774fc9a3cb99adcd778aa4693ca9ee (diff)
downloadpatches-524e5fe56b602d2ccb1dd2bf5a50a0e6ca397759.tar
patches-524e5fe56b602d2ccb1dd2bf5a50a0e6ca397759.tar.gz
gnu: Add apt-mirror.
* gnu/packages/debian.scm (apt-mirror): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/debian.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index ff4cccb03d..a3bbd2b907 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages perl))
(define-public debian-archive-keyring
@@ -190,3 +191,40 @@ scratch, without requiring the availability of @code{dpkg} or @code{apt}.
It does this by downloading .deb files from a mirror site, and carefully
unpacking them into a directory which can eventually be chrooted into.")
(license license:gpl2)))
+
+
+(define-public apt-mirror
+ (let ((commit "e664486a5d8947c2579e16dd793d762ea3de4202")
+ (revision "1"))
+ (package
+ (name "apt-mirror")
+ (version (git-version "0.5.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apt-mirror/apt-mirror/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qj6b7gldwcqyfs2kp6amya3ja7s4vrljs08y4zadryfzxf35nqq"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (arguments
+ `(#:tests? #f
+ ;; sysconfdir is not PREFIXed in the makefile but DESTDIR is
+ ;; honored correctly; we therefore use DESTDIR for our
+ ;; needs. A more correct fix would involve patching.
+ #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "PREFIX=/")
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (inputs
+ `(("wget" ,wget)
+ ("perl" ,perl)))
+ (home-page "http://apt-mirror.github.io/")
+ (synopsis "Script for mirroring a Debian repository")
+ (description
+ "apt-mirror is a small tool that provides the ability to
+selectively mirror Debian and Ubuntu GNU/Linux distributions or any
+other apt sources typically provided by open source developers.")
+ (license license:gpl2))))