summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:58:50 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commit1bd3400d8c88bca7942f37029efd15731f58b16d (patch)
tree2a0942458d19bd96c3579f68060742be9538eea4
parentb836c6500a7bdc81c6dcfcb27aa61d347bb5ad74 (diff)
downloadpatches-1bd3400d8c88bca7942f37029efd15731f58b16d.tar
patches-1bd3400d8c88bca7942f37029efd15731f58b16d.tar.gz
gnu: Add emacs-elisp-refs.
* gnu/packages/emacs.scm (emacs-elisp-refs): New public variable.
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a4163f8eb6..b4499b634a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8634,3 +8634,30 @@ tramp.")
library adds a selection of popular loop structures as well as break and
continue.")
(license license:gpl3+)))
+
+(define-public emacs-elisp-refs
+ (package
+ (name "emacs-elisp-refs")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Wilfred/elisp-refs/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fj6wphwrvbslw46w7wgdk3b4bfr312ygj3lbgr9qw63lpqw26nl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-list-utils" ,emacs-list-utils)
+ ("emacs-loop" ,emacs-loop)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/Wilfred/elisp-refs")
+ (synopsis "Find callers of elisp functions or macros")
+ (description "Find references to functions, macros or variables. Unlike a
+dumb text search, @code{elisp-refs} actually parses the code, so it's never
+confused by comments or @code{foo-bar} matching @code{foo}.")
+ (license license:gpl3+)))