summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <ecbrown@ericcbrown.com>2020-04-22 06:04:59 -0500
committerRicardo Wurmus <rekado@elephly.net>2020-04-30 13:08:33 +0200
commit1b73fbdf5e3be0d1a90432b63c5eea2cde8c456d (patch)
tree91639fb59b98944cbd18ce93681c14d6a1bd391c
parentf03e5ca59f2f099693def2c8e6ff409e5b4ed40a (diff)
downloadpatches-1b73fbdf5e3be0d1a90432b63c5eea2cde8c456d.tar
patches-1b73fbdf5e3be0d1a90432b63c5eea2cde8c456d.tar.gz
gnu: Add r-rserve.
* gnu/packages/cran.scm (r-rserve): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index baf1e0c18a..18829537e8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21633,3 +21633,40 @@ infinite-precision rational arithmetic.")
Archive Toolkit. Rxnat uses the XNAT REST API to perform data queries and
download images.")
(license license:gpl2)))
+
+(define-public r-rserve
+ (package
+ (name "r-rserve")
+ (version "1.8-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.rforge.net/Rserve/snapshot/Rserve_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "017kkzv9lxlz9qhg3gprrf1wcyflxrif6wjk27x9b4bdzylw6bsx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-checkmate" ,r-checkmate)
+ ("r-mime" ,r-mime)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-knitr" ,r-knitr)
+ ("r-r6" ,r-r6)
+ ("r-rcpp" ,r-rcpp)
+ ("r-uuid" ,r-uuid)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/s-u/Rserve")
+ (synopsis
+ "Server providing access to R from many languages and systems")
+ (description
+ "Rserve acts as a socket server (TCP/IP or local sockets) which allows
+binary requests to be sent to R. Every connection has a separate workspace
+and working directory. Client-side implementations are available for popular
+languages such as C/C++ and Java, allowing any application to use facilities
+of R without the need of linking to R code. Rserve supports remote
+connection, user authentication and file transfer. A simple R client is
+included in this package as well.")
+ (license license:gpl2)))