summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-29 13:41:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-29 13:46:07 +0200
commitff5ca61d15e979f1a91d77f950af13c76dd9b00a (patch)
tree945690a0c961f1e793b77fa6e5c6ad5f4e23bce9
parentd0e0b865e1e97679f718daf159e766c19bc09c91 (diff)
downloadpatches-ff5ca61d15e979f1a91d77f950af13c76dd9b00a.tar
patches-ff5ca61d15e979f1a91d77f950af13c76dd9b00a.tar.gz
gnu: Add python-doc8.
* gnu/packages/python-xyz.scm (python-doc8): New variable.
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 45789d7eb5..decc1ce8a6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3244,6 +3244,45 @@ reStructuredText.")
format.")
(license license:unlicense)))
+(define-public python-doc8
+ (package
+ (name "python-doc8")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "doc8" version))
+ (sha256
+ (base32
+ "0hw5w8mpgsp51qg8nnq28p7y1jiksvz7a0axnn5bkgss3af9zy1d"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v"))
+ #t)))))
+ (propagated-inputs
+ `(("python-chardet" ,python-chardet)
+ ("python-docutils" ,python-docutils)
+ ("python-restructuredtext-lint" ,python-restructuredtext-lint)
+ ("python-six" ,python-six)
+ ("python-stevedore" ,python-stevedore)))
+ (native-inputs
+ `(("python-testtools" ,python-testtools)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://launchpad.net/doc8")
+ (synopsis
+ "Style checker for Sphinx (or other) RST documentation")
+ (description
+ "Doc8 is an opinionated style checker for reStructured Text and plain
+text styles of documentation.")
+ (license license:asl2.0)))
+
(define-public python-pygments
(package
(name "python-pygments")