summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-29 13:40:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-29 13:46:07 +0200
commitd0e0b865e1e97679f718daf159e766c19bc09c91 (patch)
tree318f4762a0bca05e5b834647ab050399e5487c33
parentd08782d16c21998a493e50e2c90a183a3d4a53bb (diff)
downloadpatches-d0e0b865e1e97679f718daf159e766c19bc09c91.tar
patches-d0e0b865e1e97679f718daf159e766c19bc09c91.tar.gz
gnu: Add python-livereload.
* gnu/packages/python-web.scm (python-livereload): New variable.
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c0be3fa5d1..0dba566a77 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3627,3 +3627,26 @@ without requiring a page refresh.")
management. It can find an unused TCP localhost port and remember the
association.")
(license license:expat)))
+
+(define-public python-livereload
+ (package
+ (name "python-livereload")
+ (version "2.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "livereload" version))
+ (sha256
+ (base32
+ "0rhggz185bxc3zjnfpmhcvibyzi86i624za1lfh7x7ajsxw4y9c9"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://github.com/lepture/python-livereload")
+ (synopsis "Python LiveReload")
+ (description
+ "Python LiveReload provides a command line utility, @command{livereload},
+for starting a web server in a directory. It can trigger arbitrary commands
+and serve updated contents upon changes to the directory.")
+ (license license:bsd-3)))