summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-04-21 10:36:29 +0200
committerLeo Famulari <leo@famulari.name>2020-04-29 15:12:15 -0400
commitb9d96ed77343e3f158f7ee1c758270bf4f059a74 (patch)
tree02199bb9c83945f6cc7c4a511ef397c50f1f5e82
parent510472f865a9a21cce4ed8b1f16236ed513dbccc (diff)
downloadpatches-b9d96ed77343e3f158f7ee1c758270bf4f059a74.tar
patches-b9d96ed77343e3f158f7ee1c758270bf4f059a74.tar.gz
gnu: python-tortoise-orm: Update to 0.16.7 [security fixes].
* gnu/packages/databases.scm (python-tortoise-orm)[source]: Update to 0.16.7. [propagated-inputs]: Propagate python-ciso8601, which is required in setup.py. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 57a5128e9e..23b8f14c54 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2197,24 +2197,24 @@ can autogenerate peewee models using @code{pwiz}, a model generator.")
(define-public python-tortoise-orm
(package
(name "python-tortoise-orm")
- (version "0.16.3")
+ (version "0.16.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tortoise-orm" version))
(sha256
(base32
- "01hbvfyxs2qd1mjc96aipwsdxxhydw8ww686r4gsf87bl6f98dvz"))))
+ "0wr7p4v0b16ypm9fcpwpl99kf491m6w3jkd13xcsgq13fy73fbqc"))))
(build-system python-build-system)
;; Disable tests for now. They pull in a lot of dependencies.
(arguments `(#:tests? #f))
(native-inputs
- `(("python-ciso8601" ,python-ciso8601)
- ("python-asynctest" ,python-asynctest)
+ `(("python-asynctest" ,python-asynctest)
("python-nose2" ,python-nose2)))
(propagated-inputs
`(("python-aiosqlite" ,python-aiosqlite)
("python-pypika" ,python-pypika)
+ ("python-ciso8601" ,python-ciso8601)
("python-typing-extensions"
,python-typing-extensions)))
(home-page