summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-29 13:37:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-29 13:46:07 +0200
commit39a96b99fe66c2cf7ff8ff023f3839647332ebd9 (patch)
tree64c679d2efcb6a362e5d5a0753f13d45a94003a6
parent27cb52a20b9c697131e3d51e7bf084d6af5b5a62 (diff)
downloadpatches-39a96b99fe66c2cf7ff8ff023f3839647332ebd9.tar
patches-39a96b99fe66c2cf7ff8ff023f3839647332ebd9.tar.gz
gnu: Add python-restructuredtext-lint.
* gnu/packages/python-xyz.scm (python-restructuredtext-lint): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 31cafd47d1..45789d7eb5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3212,6 +3212,38 @@ reStructuredText.")
(base32
"0x22fs3pdmr42kvz6c654756wja305qv6cx1zbhwlagvxgr4xrji"))))))
+(define-public python-restructuredtext-lint
+ (package
+ (name "python-restructuredtext-lint")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "restructuredtext-lint" version))
+ (sha256
+ (base32
+ "026rdy5h82ng4vqxk8fnprii9d6qxf7hkygiv0a8afjvdlsxmcwp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "nosetests" "-v"))
+ #t)))))
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/twolfson/restructuredtext-lint")
+ (synopsis "reStructuredText linter")
+ (description "This package provides a linter for the reStructuredText
+format.")
+ (license license:unlicense)))
+
(define-public python-pygments
(package
(name "python-pygments")