summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-02 15:03:27 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 12:30:41 -0400
commitb2c1d4a27301b71d1273786b7aa869e5112d1e3a (patch)
treee34ff2fbf7304a79f9a08440b46592b97cd8a82a
parentae0f26b8f4e0221f1e6f1a5ebf6d5054da506761 (diff)
downloadpatches-b2c1d4a27301b71d1273786b7aa869e5112d1e3a.tar
patches-b2c1d4a27301b71d1273786b7aa869e5112d1e3a.tar.gz
gnu: Add emacs-magit-annex.
* gnu/packages/emacs-xyz.scm (emacs-magit-annex): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 96be0aa195..3bf9ffa655 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -475,6 +475,31 @@ these arguments. The prototypical use is for the command to call an external
process, passing on the arguments as command line arguments.")
(license license:gpl3+)))
+(define-public emacs-magit-annex
+ (let ((commit "ef5dce6267e9118a5eca82a22bcad0b67826c23a")
+ (revision "1"))
+ (package
+ (name "emacs-magit-annex")
+ (version (git-version "1.7.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/magit-annex.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vzkydgl889cq173zjl89g2vrddb9abc4a8gljiz3b4a7n5b1nrd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("magit" ,emacs-magit)
+ ("transient" ,emacs-transient)))
+ (home-page "https://github.com/magit/magit-annex/")
+ (synopsis "Git-annex support for Magit")
+ (description
+ "Magit-annex adds a few git-annex operations to the Magit interface.")
+ (license license:gpl3+))))
+
(define-public emacs-minions
(package
(name "emacs-minions")