summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Nicola Barbato <dnbarbato@posteo.de>2020-02-07 17:59:31 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-04-28 20:44:30 +0300
commit19e1f12ce420104451c16ab5412cb65cd8fe68cd (patch)
tree48ef6faaffff46a01f53d39a744eb7ac90e83720
parenta663b7040c3c7ed12d4f673c4ac090ad8d9b8e20 (diff)
downloadpatches-19e1f12ce420104451c16ab5412cb65cd8fe68cd.tar
patches-19e1f12ce420104451c16ab5412cb65cd8fe68cd.tar.gz
gnu: emacs-telega: Test Emacs environment on startup.
Print a more helpful error message when someone attempts to run Telega on an incompatible Emacs (e.g a 32-bit Emacs without wide ints). * gnu/packages/patches/emacs-telega-test-env.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emacs-xyz.scm (emacs-telega)[source]: Use it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm1
-rw-r--r--gnu/packages/patches/emacs-telega-test-env.patch14
3 files changed, 16 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9f212434a9..9b082a6f2a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -864,6 +864,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-magit-log-format-author-margin.patch \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
+ %D%/packages/patches/emacs-telega-test-env.patch \
%D%/packages/patches/emacs-undohist-ignored.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-zones-called-interactively.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5d2aaa4061..2c61c4189d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21376,6 +21376,7 @@ fish-completion. It can be used in both Eshell and M-x shell.")
(sha256
(base32
"0mv6i80958d9crzspzik5xh5g8326115bvg2frgv0dp9p6rm86m3"))
+ (patches (search-patches "emacs-telega-test-env.patch"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/packages/patches/emacs-telega-test-env.patch b/gnu/packages/patches/emacs-telega-test-env.patch
new file mode 100644
index 0000000000..75fe2e12fc
--- /dev/null
+++ b/gnu/packages/patches/emacs-telega-test-env.patch
@@ -0,0 +1,14 @@
+Test Emacs environment on startup.
+
+Patch by Diego N. Barbato
+
+--- a/telega.el 2020-02-07 17:07:18.549970090 +0100
++++ b/telega.el 2020-02-07 17:10:08.383499765 +0100
+@@ -82,6 +82,7 @@
+ "Start telegramming.
+ If prefix ARG is given, then will not pop to telega root buffer."
+ (interactive "P")
++ (telega-test-env t)
+ (telega--create-hier)
+
+ (unless (telega-server-live-p)