summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:21:16 -0400
committerGuix Patches Tester <>2020-04-28 20:53:11 +0100
commitf91a684cb299f18e8e5f418bf4c85875534d9493 (patch)
tree0a2b4e30a369c187caf64d1a000c08966b8c6b55
parenta3868eac8d17168988c0fbe83ce47a274231e189 (diff)
downloadpatches-f91a684cb299f18e8e5f418bf4c85875534d9493.tar
patches-f91a684cb299f18e8e5f418bf4c85875534d9493.tar.gz
gnu: Add python-pytest-testmon.
* gnu/packages/python-xyz.scm (python-pytest-testmon): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0a031baac2..062dfe1d2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19694,3 +19694,25 @@ Open Sound Control 1.0} specification.")
(description "Python modules for text manipulation.")
(license #f)))
+(define-public python-pytest-testmon
+ (package
+ (name "python-pytest-testmon")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-testmon" version))
+ (sha256
+ (base32
+ "1iasz23zrzjgbak8jiq12i4zmkk8f6dmcdhfxz8m2q03agcidc7x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://testmon.org")
+ (synopsis
+ "Selects tests affected by changed files and methods")
+ (description
+ "Pytest module for selecting tests affected by changed files and
+methods.")
+ (license #f)))