summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:19:04 -0400
committerGuix Patches Tester <>2020-04-28 20:53:10 +0100
commitba03d918c3733e464f924322b6e1e7efe306f34d (patch)
tree42139f7f9a37743ca2e95f679a33b2d97abcf7d3
parent08f4680cb13cb10a9d53467f066c8106fa7dd372 (diff)
downloadpatches-ba03d918c3733e464f924322b6e1e7efe306f34d.tar
patches-ba03d918c3733e464f924322b6e1e7efe306f34d.tar.gz
gnu: Add python-jaraco-functools.
* gnu/packages/python-xyz.scm (python-jaraco-functools): New variable.
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f333af9e3..54a0ac36bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19626,3 +19626,43 @@ Open Sound Control 1.0} specification.")
"This package provides utility functions for Python class constructs.")
(license #f)))
+(define-public python-jaraco-functools
+ (package
+ (name "python-jaraco-functools")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.functools" version))
+ (sha256
+ (base32
+ "15vd7x4jillggb8xcg3cm00j1v6llhl16r0rqm0l4n2lyahfxc2w"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Not importing the googleapis package for now
+ (add-after 'unpack 'ignore-googleapis
+ (lambda _
+ (substitute* "setup.py"
+ (("'pytest-black-multipy',") ""))
+ #t)))))
+ (propagated-inputs
+ `(("python-more-itertools" ,python-more-itertools)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-jaraco-classes" ,python-jaraco-classes)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-checkdocs"
+ ,python-pytest-checkdocs)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-six" ,python-six)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page
+ "https://github.com/jaraco/jaraco.functools")
+ (synopsis "Functools like those found in stdlib")
+ (description
+ "This package provides functools like those found in stdlib.")
+ (license #f)))
+