summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:20:54 -0400
committerGuix Patches Tester <>2020-04-28 20:53:11 +0100
commita3868eac8d17168988c0fbe83ce47a274231e189 (patch)
tree8a35b709892adc6461ba3c812875c92c6b036cb3
parentba03d918c3733e464f924322b6e1e7efe306f34d (diff)
downloadpatches-a3868eac8d17168988c0fbe83ce47a274231e189.tar
patches-a3868eac8d17168988c0fbe83ce47a274231e189.tar.gz
gnu: Add python-jarco-text.
* gnu/packages/python-xyz.scm (python-jarco-text): New variable.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54a0ac36bd..0a031baac2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19666,3 +19666,31 @@ Open Sound Control 1.0} specification.")
"This package provides functools like those found in stdlib.")
(license #f)))
+(define-public python-jaraco-text
+ (package
+ (name "python-jaraco-text")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.text" version))
+ (sha256
+ (base32
+ "1v0hz3h74m31jlbc5bxwkvrx1h2n7887bajrg1n1c3yc4q8qn1z5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-jaraco-functools" ,python-jaraco-functools)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-checkdocs"
+ ,python-pytest-checkdocs)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)))
+ (home-page
+ "https://github.com/jaraco/jaraco.text")
+ (synopsis "Module for text manipulation")
+ (description "Python modules for text manipulation.")
+ (license #f)))
+