summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:21:36 -0400
committerGuix Patches Tester <>2020-04-28 20:53:12 +0100
commita1a27f5c98663acee871a436b5a582c90eb3fe64 (patch)
treecb664c4cdce5abba19cf2322eac72f0f9af39a9d
parentf91a684cb299f18e8e5f418bf4c85875534d9493 (diff)
downloadpatches-a1a27f5c98663acee871a436b5a582c90eb3fe64.tar
patches-a1a27f5c98663acee871a436b5a582c90eb3fe64.tar.gz
gnu: Add python-pytest-watch.
* gnu/packages/python-xyz.scm (python-pytest-watch): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 062dfe1d2b..d9a972c456 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19716,3 +19716,29 @@ Open Sound Control 1.0} specification.")
"Pytest module for selecting tests affected by changed files and
methods.")
(license #f)))
+
+(define-public python-pytest-watch
+ (package
+ (name "python-pytest-watch")
+ (version "4.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-watch" version))
+ (sha256
+ (base32
+ "1fflnd3varpqy8yzcs451n8h7wmjyx1408qdin5p2qdksl1ny4q6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-docopt" ,python-docopt)
+ ("python-pytest" ,python-pytest)
+ ("python-watchdog" ,python-watchdog)))
+ (home-page
+ "http://github.com/joeyespo/pytest-watch")
+ (synopsis
+ "Local continuous test runner for pytest and watchdog")
+ (description
+ "This package provides a local continuous test runner for pytest
+and watchdog.")
+ (license license:expat)))