summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:22:54 -0400
committerGuix Patches Tester <>2020-04-28 20:53:14 +0100
commit629b541c19d87110a9045a05e50bc226abc368c5 (patch)
tree720bf6129ee8e1c596f5b34a2802f8145f3d46da
parentd103407d8dbd2b477245df10eb98e17ccf75059b (diff)
downloadpatches-629b541c19d87110a9045a05e50bc226abc368c5.tar
patches-629b541c19d87110a9045a05e50bc226abc368c5.tar.gz
gnu: Add python-markdown2.
* gnu/packages/python-xyz.scm (python-markdown2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60839d646c..3af73e62c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19854,3 +19854,24 @@ and watchdog.")
(description
"Cheroot is the pure-Python HTTP server used by CherryPy.")
(license #f)))
+
+(define-public python-markdown2
+ (package
+ (name "python-markdown2")
+ (version "2.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "markdown2" version))
+ (sha256
+ (base32
+ "1gjxy3j7qgl0fzmdqd0jx0gv13s1z9n1g3fd3s72rh4nnc08xy3z"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/trentm/python-markdown2")
+ (synopsis
+ "A fast and complete Python implementation of Markdown")
+ (description
+ "A Python implementation of Markdown which aims to closely match
+the behavior of the original perl-implemented Markdown.pl.")
+ (license license:expat)))