summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-04-28 15:22:01 -0400
committerGuix Patches Tester <>2020-04-28 20:53:13 +0100
commit1092b982a90237f27e59d5e8153383e1e06f9bed (patch)
tree9457fcf13cd2d65b662d37b82108c38de41d930f
parenta1a27f5c98663acee871a436b5a582c90eb3fe64 (diff)
downloadpatches-1092b982a90237f27e59d5e8153383e1e06f9bed.tar
patches-1092b982a90237f27e59d5e8153383e1e06f9bed.tar.gz
gnu: Add python-requests-unixsocket.
* gnu/packages/python-xyz.scm (python-requests-unixsocket): New variable.
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d9a972c456..2c354c8d71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19742,3 +19742,39 @@ methods.")
"This package provides a local continuous test runner for pytest
and watchdog.")
(license license:expat)))
+
+(define-public python-requests-unixsocket
+ (package
+ (name "python-requests-unixsocket")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-unixsocket" version))
+ (sha256
+ (base32
+ "1sn12y4fw1qki5gxy9wg45gmdrxhrndwfndfjxhpiky3mwh1lp4y"))))
+ ;; why tied to waitress==0.9.0 I have no idea
+ (arguments
+ ;; We don't have all the test deps yet... missing pyttest-cache
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Not importing the googleapis package for now
+ (add-after 'unpack 'ignore-googleapis
+ (lambda _
+ (delete-file "test-requirements.txt")
+ #t)))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)
+ ("python-urllib3" ,python-urllib3)))
+ (native-inputs
+ `(("python-pbr-minimal" ,python-pbr-minimal)))
+ (home-page
+ "https://github.com/msabramo/requests-unixsocket")
+ (synopsis
+ "Use requests to talk HTTP via a UNIX domain socket")
+ (description
+ "Use the Python requests library to talk HTTP via a UNIX domain socket.")
+ (license #f)))