summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 10:45:18 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 11:47:45 +0200
commitd27f033f97ab7a71e0a3af004d3e11bea9374676 (patch)
treeb4f83925a35adb111c60350b6b8142526a6b719a
parent8f46a9d67f54ffbe04d4201bdfcc8b460f640805 (diff)
downloadpatches-d27f033f97ab7a71e0a3af004d3e11bea9374676.tar
patches-d27f033f97ab7a71e0a3af004d3e11bea9374676.tar.gz
gnu: sbcl-cl-cffi-gtk-pango: Link source to parent to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-cl-cffi-gtk-pango)[arguments]: Replace source folder with link to the same folder in the sbcl-cl-cffi-gtk-glib dependency.
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e938bd6aa2..b2b5e006a6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3015,7 +3015,20 @@ is a library for creating graphical user interfaces.")
(substitute* "pango/pango.init.lisp"
(("libpango" all)
(string-append
- (assoc-ref inputs "pango") "/lib/" all))))))))))
+ (assoc-ref inputs "pango") "/lib/" all)))))
+ (add-after 'install 'link-source
+ ;; Since source is particularly heavy (16MiB+), let's reuse it
+ ;; across the different components of cl-ffi-gtk.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((glib-source (string-append (assoc-ref inputs "cl-cffi-gtk-glib")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-glib"))
+ (out-source (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-pango")))
+ (delete-file-recursively out-source)
+ (symlink glib-source out-source)
+ #t))))))))
(define-public sbcl-cl-cffi-gtk-gdk-pixbuf
(package