summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-22 22:43:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-22 22:46:06 +0100
commitcd7e688596aa2dc9f48e0b5efb760fd0e889b406 (patch)
tree35c7d98ddfe6b9372a918f7380db1c6c0ce15850
parent026a0ba90274fb32c84441e42e492887168acdc2 (diff)
downloadpatches-cd7e688596aa2dc9f48e0b5efb760fd0e889b406.tar
patches-cd7e688596aa2dc9f48e0b5efb760fd0e889b406.tar.gz
gnu: cpupower: Fix library location.
* gnu/packages/linux.scm (cpupower)[arguments]: Add a ‘libdir’ to #:make-flags.
-rw-r--r--gnu/packages/linux.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a7a80809d6..c93ed8e387 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4519,6 +4519,7 @@ from that to the system kernel's @file{/dev/random} machinery.")
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "DESTDIR=" out)
(string-append "LDFLAGS=-Wl,-rpath=" out "/lib")
+ "libdir=/lib"
"docdir=/share/doc/cpupower"
"confdir=$(docdir)/examples"
;; The Makefile recommends the following changes