summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 10:45:05 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 11:47:45 +0200
commit8f46a9d67f54ffbe04d4201bdfcc8b460f640805 (patch)
treea99ebe3875765433e8bff65fb5f2d904a64ba129
parent6a7f36686499086086b23cb7238c91c899de7f67 (diff)
downloadpatches-8f46a9d67f54ffbe04d4201bdfcc8b460f640805.tar
patches-8f46a9d67f54ffbe04d4201bdfcc8b460f640805.tar.gz
gnu: sbcl-cl-cffi-gtk-cairo: Link source to parent to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-cl-cffi-gtk-cairo)[arguments]: Replace source folder with link to the same folder in the sbcl-cl-cffi-gtk-glib dependency.
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fbb502cc73..e938bd6aa2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2981,7 +2981,20 @@ is a library for creating graphical user interfaces.")
(substitute* "cairo/cairo.init.lisp"
(("libcairo" all)
(string-append
- (assoc-ref inputs "cairo") "/lib/" all))))))))))
+ (assoc-ref inputs "cairo") "/lib/" all)))))
+ (add-after 'install 'link-source
+ ;; Since source is particularly heavy (16MiB+), let's reuse it
+ ;; across the different components of cl-ffi-gtk.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((glib-source (string-append (assoc-ref inputs "cl-cffi-gtk-glib")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-glib"))
+ (out-source (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-cairo")))
+ (delete-file-recursively out-source)
+ (symlink glib-source out-source)
+ #t))))))))
(define-public sbcl-cl-cffi-gtk-pango
(package