summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 10:44:47 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 11:47:45 +0200
commit6a7f36686499086086b23cb7238c91c899de7f67 (patch)
tree10ae690b2116bdf7f8a1741ec6d48afb77c362cd
parenteac71f54fe561aadc02067d114c8f32ff3f359cb (diff)
downloadpatches-6a7f36686499086086b23cb7238c91c899de7f67.tar
patches-6a7f36686499086086b23cb7238c91c899de7f67.tar.gz
gnu: sbcl-cl-cffi-gtk-gio: Link source to parent to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-cl-cffi-gtk-gio)[arguments]: Replace source folder with link to the same folder in the sbcl-cl-cffi-gtk-glib dependency.
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b8efaf985f..fbb502cc73 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2949,7 +2949,20 @@ is a library for creating graphical user interfaces.")
(substitute* "gio/gio.init.lisp"
(("libgio" all)
(string-append
- (assoc-ref inputs "glib") "/lib/" all))))))))))
+ (assoc-ref inputs "glib") "/lib/" all)))))
+ (add-after 'install 'link-source
+ ;; Since source is particularly heavy (16MiB+), let's reuse it
+ ;; across the different components of cl-ffi-gtk.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((glib-source (string-append (assoc-ref inputs "cl-cffi-gtk-glib")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-glib"))
+ (out-source (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-gio")))
+ (delete-file-recursively out-source)
+ (symlink glib-source out-source)
+ #t))))))))
(define-public sbcl-cl-cffi-gtk-cairo
(package