summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-20 03:45:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-24 11:05:55 +0200
commit56042d790aa226c6c334be949b88877171a00c73 (patch)
treea67701809f80ea0f948edcf28b8dc3047c1a867b
parente78e3be3e5d77166e21f9b42d4fe288df9a8f026 (diff)
downloadpatches-56042d790aa226c6c334be949b88877171a00c73.tar
patches-56042d790aa226c6c334be949b88877171a00c73.tar.gz
gnu: Add rust-gzip-header-0.3.
* gnu/packages/crates-io.scm (rust-gzip-header-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 43411d7a8c..0ba6b3f5d4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6012,6 +6012,30 @@ standard printing of search results, similar to grep itself.")
"Fast line oriented regex searching as a library.")
(license (list license:unlicense license:expat))))
+(define-public rust-gzip-header-0.3
+ (package
+ (name "rust-gzip-header")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gzip-header" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fg6vm8sgsm69szwqyz7abfbyziv6pv0jkcailimlamvsfrzwc81"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-crc32fast" ,rust-crc32fast-1.2))))
+ (home-page "https://github.com/oyvindln/gzip-header")
+ (synopsis "Decoding and encoding the header part of gzip files")
+ (description
+ "This package provides a crate for decoding and encoding the header part
+of gzip files based on the gzip header implementation in the @code{flate2} crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-half-1.3
(package
(name "rust-half")