summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 10:45:32 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-28 11:47:45 +0200
commit2666a3361ec76fefe10257da3c6eb0f854ed24db (patch)
tree5ea9c164d523660c54ad8bba225f6aade8ecb42f
parentd27f033f97ab7a71e0a3af004d3e11bea9374676 (diff)
downloadpatches-2666a3361ec76fefe10257da3c6eb0f854ed24db.tar
patches-2666a3361ec76fefe10257da3c6eb0f854ed24db.tar.gz
gnu: sbcl-cl-cffi-gtk-gdk-pixbuf: Link source to parent to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-cl-cffi-gtk-gdk-pixbuf)[arguments]: Replace source folder with link to the same folder in the sbcl-cl-cffi-gtk-glib dependency.
-rw-r--r--gnu/packages/lisp-xyz.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b2b5e006a6..fa86769872 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3037,6 +3037,7 @@ is a library for creating graphical user interfaces.")
(inputs
`(("gdk-pixbuf" ,gdk-pixbuf)
("cl-cffi-gtk-gobject" ,sbcl-cl-cffi-gtk-gobject)
+ ("cl-cffi-gtk-glib" ,sbcl-cl-cffi-gtk-glib)
,@(package-inputs sbcl-cl-cffi-gtk-boot0)))
(arguments
`(#:asd-file "gdk-pixbuf/cl-cffi-gtk-gdk-pixbuf.asd"
@@ -3047,7 +3048,20 @@ is a library for creating graphical user interfaces.")
(substitute* "gdk-pixbuf/gdk-pixbuf.init.lisp"
(("libgdk_pixbuf" all)
(string-append
- (assoc-ref inputs "gdk-pixbuf") "/lib/" all))))))))))
+ (assoc-ref inputs "gdk-pixbuf") "/lib/" all)))))
+ (add-after 'install 'link-source
+ ;; Since source is particularly heavy (16MiB+), let's reuse it
+ ;; across the different components of cl-ffi-gtk.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((glib-source (string-append (assoc-ref inputs "cl-cffi-gtk-glib")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-glib"))
+ (out-source (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-gdk-pixbuf")))
+ (delete-file-recursively out-source)
+ (symlink glib-source out-source)
+ #t))))))))
(define-public sbcl-cl-cffi-gtk-gdk
(package