summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-27 17:30:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-28 08:44:03 +0200
commit169f9fe13a4afd7ea4d51d26ce676e6eeb51f160 (patch)
tree4bec8b505615d31e63e447367090ffe61706003f
parent5ffe706b84c2bb870410a3841a29e68a2b5d4683 (diff)
downloadpatches-169f9fe13a4afd7ea4d51d26ce676e6eeb51f160.tar
patches-169f9fe13a4afd7ea4d51d26ce676e6eeb51f160.tar.gz
gnu: Add r-qgam.
* gnu/packages/cran.scm (r-qgam): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5058079249..3b20ced31a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16949,6 +16949,39 @@ for original research. A variety of user defined options and formatting are
included.")
(license license:gpl3)))
+(define-public r-qgam
+ (package
+ (name "r-qgam")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "qgam" version))
+ (sha256
+ (base32
+ "0lks2cj0p7irp1i01756v1l7i26d7alax1fbkc20qd6wpz840fi7"))))
+ (properties `((upstream-name . "qgam")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-doparallel" ,r-doparallel)
+ ("r-mgcv" ,r-mgcv)
+ ("r-plyr" ,r-plyr)
+ ("r-shiny" ,r-shiny)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/qgam/")
+ (synopsis "Smooth additive quantile regression models")
+ (description
+ "This package provides smooth additive quantile regression models, fitted
+using the methods of Fasiolo et al. (2017). Differently from @code{quantreg},
+the smoothing parameters are estimated automatically by marginal loss
+minimization, while the regression coefficients are estimated using either
+PIRLS or Newton algorithm. The learning rate is determined so that the
+Bayesian credible intervals of the estimated effects have approximately the
+correct coverage. The main function is @code{qgam()} which is similar to
+@code{gam()} in the @code{mgcv} package, but fits non-parametric quantile
+regression models.")
+ (license license:gpl2+)))
+
(define-public r-abtest
(package
(name "r-abtest")