summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-28 12:20:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-28 12:23:28 +0200
commit0b2c88382830e281912cc04867f45e15c2f9657f (patch)
treeda888dd52f7da7acdf67ddce1f13639515903390
parent9a2fcb6325eb652971de4936911267d1fc5bb549 (diff)
downloadpatches-0b2c88382830e281912cc04867f45e15c2f9657f.tar
patches-0b2c88382830e281912cc04867f45e15c2f9657f.tar.gz
gnu: Add hdf5-blosc.
* gnu/packages/maths.scm (hdf5-blosc): New variable.
-rw-r--r--gnu/packages/maths.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 73ee161e81..d7ce900682 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -1298,6 +1298,45 @@ Swath).")
#t))))))
(synopsis "Management suite for data with parallel IO support")))
+(define-public hdf5-blosc
+ (package
+ (name "hdf5-blosc")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Blosc/hdf5-blosc.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nj2bm1v6ymm3fmyvhbn6ih5fgdiapavlfghh1pvbmhw71cysyqs"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DBLOSC_INSTALL_DIR="
+ (assoc-ref %build-inputs "c-blosc"))
+ (string-append "-DPLUGIN_INSTALL_PATH="
+ (assoc-ref %outputs "out")
+ "/hdf5/lib/plugin"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'do-not-build-blosc
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set\\(BLOSC_INSTALL_DIR.*") "")
+ (("ExternalProject_Add\\(project_blosc") "message("))
+ #t)))))
+ (inputs
+ `(("c-blosc" ,c-blosc)
+ ("hdf5" ,hdf5-1.10)))
+ (home-page "https://github.com/Blosc/hdf5-blosc")
+ (synopsis "Filter for HDF5 using the Blosc compressor")
+ (description "This is a filter for HDF5 that uses the Blosc compressor; by
+installing this filter, you can read and write HDF5 files with
+Blosc-compressed datasets.")
+ (license license:expat)))
+
(define-public h5check
(package
(name "h5check")