summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-27 16:22:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-28 08:44:02 +0200
commit50f298a54f4db6a34406ca475909b800c24fee69 (patch)
tree42f89652fff1d027b007b0f83d00f4fa6627b632
parentbefa394f454901c51a735acf495d701464823a38 (diff)
downloadpatches-50f298a54f4db6a34406ca475909b800c24fee69.tar
patches-50f298a54f4db6a34406ca475909b800c24fee69.tar.gz
gnu: Add r-ibreakdown.
* gnu/packages/cran.scm (r-ibreakdown): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b8549ec3e3..f5e69fb1bc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15397,6 +15397,32 @@ feature effects. Key functions are:
@end itemize\n")
(license license:gpl3)))
+(define-public r-ibreakdown
+ (package
+ (name "r-ibreakdown")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "iBreakDown" version))
+ (sha256
+ (base32
+ "0y4zjpyn8j76jrs5phjzs5lfq3lqjspmrwcksqv9wq0rbdgh14vk"))))
+ (properties `((upstream-name . "iBreakDown")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-ggplot2" ,r-ggplot2)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://ModelOriented.github.io/iBreakDown/")
+ (synopsis "Model agnostic instance level variable attributions")
+ (description
+ "This package provides a model agnostic tool for decomposition of
+predictions from black boxes. It supports additive attributions and
+attributions with interactions. The Break Down Table shows contributions of
+every variable to a final prediction. The Break Down Plot presents variable
+contributions in a concise graphical way. This package works for
+classification and regression models.")
+ (license license:gpl3)))
+
(define-public r-dalex
(package
(name "r-dalex")