summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-03-12 18:50:59 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-03-12 18:56:34 +0100
commit2ffec22eeb5cdc7d95472aaf1a402c831be1f407 (patch)
treec26891709feffad566dac24d7c104a6a5ce5836d
parent7458ceaca8f207924f35cdf8bebaa537d88261b2 (diff)
downloadpatches-2ffec22eeb5cdc7d95472aaf1a402c831be1f407.tar
patches-2ffec22eeb5cdc7d95472aaf1a402c831be1f407.tar.gz
gnu: python-pygit2: Update to 0.27.4.
* gnu/packages/python-xyz.scm (python-pygit2): Update to 0.27.4. (python-pygit2)[arguments]: Disable tests.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8406e33591..1f8e00fdfd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3220,26 +3220,19 @@ color scales, and color space conversion easy. It has support for:
(define-public python-pygit2
(package
(name "python-pygit2")
- (version "0.27.3")
+ (version "0.27.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pygit2" version))
(sha256
(base32
- "046ahvsb7a20sgvscqfm3cb32sp3sii4gim9vz7zzrkf7yz16xlv"))))
+ "15c1mhwwjc7nr8hn5gm21hcfhw61jmwb0vngpjhlm3y5565wg2pz"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ '(#:tests? #f; tests don't run correctly in our environment
+ #:phases
(modify-phases %standard-phases
- ;; Remove after the next update. See:
- ;; https://github.com/libgit2/pygit2/pull/851
- (add-after 'unpack 'compile-with-cffi
- (lambda _
- (substitute* "setup.py"
- (("install_requires")
- "setup_requires=['cffi'],\n install_requires"))
- #t))
(add-after 'unpack 'fix-dependency-versioning
(lambda _
(substitute* "setup.py"