summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2019-02-02 11:01:02 +0100
committerClément Lassieur <clement@lassieur.org>2019-02-02 11:14:39 +0100
commit57b663fa8fcc22d9c89fd919aca4c3c13465c819 (patch)
tree23715eaefec42870447cda0aadbcfa3b82fd6265
parentba25ba903d72ffb287846bea4e151dbc21d2f45d (diff)
downloadpatches-57b663fa8fcc22d9c89fd919aca4c3c13465c819.tar
patches-57b663fa8fcc22d9c89fd919aca4c3c13465c819.tar.gz
gnu: Add emacs-repo.
* gnu/packages/emacs-xyz.scm (emacs-repo): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 785bb84d88..081d7570fa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13014,3 +13014,30 @@ indentation offset originally used for creating source code files and
transparently adjusts the corresponding settings in Emacs, making it more
convenient to edit foreign files.")
(license license:gpl2+)))
+
+(define-public emacs-repo
+ (package
+ (name "emacs-repo")
+ (version "0.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/canatella/repo-el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rbvcvm7bfr6ncji7cllfxyyr6x7n9fx863byp243phsj3n93adz"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-el-mock" ,emacs-el-mock)
+ ("ert-runner" ,emacs-ert-runner)))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("magit" ,emacs-magit)))
+ (home-page "https://github.com/canatella/repo-el")
+ (synopsis "Emacs interface for the Google Repo tool")
+ (description "This package provides integration of the Google Repo tool
+with emacs. It displays the output of the @code{repo status} command in a
+buffer and launches Magit from the status buffer for the project at point.")
+ (license license:gpl3+)))