summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 13:39:25 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 13:39:25 +0200
commitc43edf6f3012436aef8196a406bb407beda3e533 (patch)
treef80fb84b5314f0dcc1610bd62d5776565f3e6512
parent4c24186ae0798cd3263c1647d5f9aab0719b3d15 (diff)
downloadpatches-c43edf6f3012436aef8196a406bb407beda3e533.tar
patches-c43edf6f3012436aef8196a406bb407beda3e533.tar.gz
gnu: Add python-deeptoolsintervals.
* gnu/packages/bioinformatics.scm (python-deeptoolsintervals): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6c5b49e37e..cd401d97f3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2334,6 +2334,27 @@ file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
files. The code was previously part of the cutadapt tool.")
(license license:expat)))
+(define-public python-deeptoolsintervals
+ (package
+ (name "python-deeptoolsintervals")
+ (version "0.1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "deeptoolsintervals" version))
+ (sha256
+ (base32
+ "1xnl80nblysj6dylj4683wgrfa425rkx4dp5k65hvwdns9pw753x"))))
+ (build-system python-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/deeptools/deeptools_intervals")
+ (synopsis "Create GTF-based interval trees with associated meta-data")
+ (description
+ "This package provides a Python module creating/accessing GTF-based
+interval trees with associated meta-data. It is primarily used by the
+@code{deeptools} package.")
+ (license license:expat)))
+
(define-public cutadapt
(package
(name "cutadapt")