summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 10:43:51 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 10:43:51 +0200
commit8ce240fdbf05539b0d13f981b0520be5d84e0e61 (patch)
tree8e00520a0785ae430ff1a866e7a4b7d8508d8687
parentcb1ab0352b1f70dd1a5c56c7bd12de82c0b7fde5 (diff)
downloadpatches-8ce240fdbf05539b0d13f981b0520be5d84e0e61.tar
patches-8ce240fdbf05539b0d13f981b0520be5d84e0e61.tar.gz
gnu: Add r-bsgenome-hsapiens-ucsc-hg38.
* gnu/packages/bioconductor.scm (r-bsgenome-hsapiens-ucsc-hg38): New variable.
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d74d1cf706..66ff6114c3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -493,6 +493,30 @@ annotations for the genome of the model mouse Mus musculus.")
by UCSC (hg19, February 2009) and stored in Biostrings objects.")
(license license:artistic2.0)))
+(define-public r-bsgenome-hsapiens-ucsc-hg38
+ (package
+ (name "r-bsgenome-hsapiens-ucsc-hg38")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BSgenome.Hsapiens.UCSC.hg38"
+ version 'annotation))
+ (sha256
+ (base32
+ "1ql08pvi4vv0ynvg4qs9kysw1c7s3crkgin6zxvgzqk6fray9mvi"))))
+ (properties
+ `((upstream-name . "BSgenome.Hsapiens.UCSC.hg38")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)))
+ (home-page
+ "https://www.bioconductor.org/packages/BSgenome.Hsapiens.UCSC.hg38/")
+ (synopsis "Full genome sequences for Homo sapiens")
+ (description
+ "This package provides full genome sequences for Homo sapiens (Human)
+as provided by UCSC (hg38, Dec. 2013) and stored in Biostrings objects.")
+ (license license:artistic2.0)))
+
(define-public r-ensdb-hsapiens-v75
(package
(name "r-ensdb-hsapiens-v75")