summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 13:54:43 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 13:54:43 +0200
commit639ae3f20bea5ccd7f4a4df7a828569639220e79 (patch)
treeba6ee9f886affc21464d52c00dfb9f961a7d7ad1
parentccf70a80a12be86ed609ce7d37d3ae32f75edc39 (diff)
downloadpatches-639ae3f20bea5ccd7f4a4df7a828569639220e79.tar
patches-639ae3f20bea5ccd7f4a4df7a828569639220e79.tar.gz
gnu: Add python-scikit-rebate.
* gnu/packages/machine-learning.scm (python-scikit-rebate): New variable.
-rw-r--r--gnu/packages/machine-learning.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 9a88b53415..223d03e979 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -867,6 +867,35 @@ data analysis.")
(base32
"08zbzi8yx5wdlxfx9jap61vg1malc9ajf576w7a0liv6jvvrxlpj")))))))
+(define-public python-scikit-rebate
+ (package
+ (name "python-scikit-rebate")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "skrebate" version))
+ (sha256
+ (base32
+ "1h7qs9gjxpzqabzhb8rmpv3jpmi5iq41kqdibg48299h94iikiw7"))))
+ (build-system python-build-system)
+ ;; Pandas is only needed to run the tests.
+ (native-inputs
+ `(("python-pandas" ,python-pandas)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-joblib" ,python-joblib)))
+ (home-page "https://epistasislab.github.io/scikit-rebate/")
+ (synopsis "Relief-based feature selection algorithms for Python")
+ (description "Scikit-rebate is a scikit-learn-compatible Python
+implementation of ReBATE, a suite of Relief-based feature selection algorithms
+for Machine Learning. These algorithms excel at identifying features that are
+predictive of the outcome in supervised learning problems, and are especially
+good at identifying feature interactions that are normally overlooked by
+standard feature selection algorithms.")
+ (license license:expat)))
+
(define-public python-autograd
(let* ((commit "442205dfefe407beffb33550846434baa90c4de7")
(revision "0")