summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 13:09:02 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 13:09:02 +0200
commit4c24186ae0798cd3263c1647d5f9aab0719b3d15 (patch)
treeabdc5826fbdc53e24da52675fc3c9b581b9bfd85
parent06fc1a51427f5af0e337e16602cb4920865d54fb (diff)
downloadpatches-4c24186ae0798cd3263c1647d5f9aab0719b3d15.tar
patches-4c24186ae0798cd3263c1647d5f9aab0719b3d15.tar.gz
gnu: Add python-bitarray.
* gnu/packages/python-xyz.scm (python-bitarray): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9460a59e31..31cafd47d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
-;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
@@ -640,6 +640,30 @@ certificate returned by the server to which a connection has been established,
and verifies that it matches the intended target hostname.")
(license license:psfl)))
+(define-public python-bitarray
+ (package
+ (name "python-bitarray")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bitarray" version))
+ (sha256
+ (base32
+ "1kxrlxfj9nrx512sfwifwl9z4v6ky3qschl0zmk3s3dvc3s7bmif"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/ilanschnell/bitarray")
+ (synopsis "Efficient arrays of booleans")
+ (description "This package provides an object type which efficiently
+represents an array of booleans. Bitarrays are sequence types and behave very
+much like usual lists. Eight bits are represented by one byte in a contiguous
+block of memory. The user can select between two representations:
+little-endian and big-endian. All of the functionality is implemented in C.
+Methods for accessing the machine representation are provided. This can be
+useful when bit level access to binary files is required, such as portable
+bitmap image files. Also, when dealing with compressed data which uses
+variable bit length encoding, you may find this module useful.")
+ (license license:psfl)))
+
(define-public python-boolean.py
(package
(name "python-boolean.py")