summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 11:46:08 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 11:46:08 +0200
commit06fc1a51427f5af0e337e16602cb4920865d54fb (patch)
tree3ca68e39a367514a1b862f1a20514758d744a233
parent91370829f4b7d043673e283466d1795143e91684 (diff)
downloadpatches-06fc1a51427f5af0e337e16602cb4920865d54fb.tar
patches-06fc1a51427f5af0e337e16602cb4920865d54fb.tar.gz
gnu: Add r-cummerbund.
* gnu/packages/bioconductor.scm (r-cummerbund): New variable.
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 83ac5dcf7c..b4be8aee15 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1096,6 +1096,36 @@ experiment types where it is important to have a framework in order to inspect
how the coverage distributed across the genome.")
(license license:artistic2.0)))
+(define-public r-cummerbund
+ (package
+ (name "r-cummerbund")
+ (version "2.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "cummeRbund" version))
+ (sha256
+ (base32
+ "1fjc3bcclm4gsvw4nq6cv3a1kbrldvrxbkyfb9306708si1n4dwk"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-fastcluster", r-fastcluster)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gviz" ,r-gviz)
+ ("r-plyr" ,r-plyr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/cummeRbund/")
+ (synopsis "Analyze Cufflinks high-throughput sequencing data")
+ (description "This package allows for persistent storage, access,
+exploration, and manipulation of Cufflinks high-throughput sequencing
+data. In addition, provides numerous plotting functions for commonly
+used visualizations.")
+ (license license:artistic2.0)))
+
(define-public r-curatedtcgadata
(package
(name "r-curatedtcgadata")