summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-26 12:34:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-26 13:31:15 +0200
commitf989dffd2c568de2082d5fe9722588e2fc0cec1f (patch)
tree310ab70059e82f520f134dcc26c829e5c680a37f
parent660611e5f6e5010339a7c72ef264cdb1f43a8f55 (diff)
downloadpatches-f989dffd2c568de2082d5fe9722588e2fc0cec1f.tar
patches-f989dffd2c568de2082d5fe9722588e2fc0cec1f.tar.gz
gnu: thinkfan: Adjust for Guile 3.0.
* gnu/packages/linux.scm (thinkfan)[arguments]: Provide explicit destination in calls to FORMAT (destination is no longer optional with Guile 3).
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f2d45eb07a..9a8bbc78d8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4675,7 +4675,7 @@ feature, and a laptop with an accelerometer. It has no effect on SSDs.")
(share (string-append out "/share/" ,name)))
(substitute* "CMakeLists.txt"
(("pkg_check_modules\\((OPENRC|SYSTEMD) .*" _ package)
- (format "option(~a_FOUND \"Faked\" ON)\n" package))
+ (format #f "option(~a_FOUND \"Faked\" ON)\n" package))
;; That was easy! Now we just need to fix the destinations.
(("/etc" directory)
(string-append out directory)))