summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmar Singh <nly@disroot.org>2019-04-22 01:28:32 +0530
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-11 22:35:26 +0200
commita38525789cdb6b4baa440cdf9f265085d4378ec5 (patch)
treeceef9216db16880c0f5831f8c00fd44d6a6a6d81
parent2be6b5e2eea9ac084cc22281f64f7a089e46cdae (diff)
downloadpatches-a38525789cdb6b4baa440cdf9f265085d4378ec5.tar
patches-a38525789cdb6b4baa440cdf9f265085d4378ec5.tar.gz
gnu: Add emacs-shroud.
* gnu/packages/emacs-xyz.scm (emacs-shroud): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2eb705dedd..ca1eb586df 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
+;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -545,6 +546,35 @@ handful of functions that are not resource-specific.")
for editing Racket's Scribble documentation syntax in Emacs.")
(license license:gpl3+))))
+(define-public emacs-shroud
+ (package
+ (name "emacs-shroud")
+ (version "1.15.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/o-nly/emacs-shroud.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wvm4lxqcc1p8v7rpqal3bnqgnpk1gs7v18i83f6cvi5d88jkgdg"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-bui" ,emacs-bui)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("gnupg" ,gnupg)
+ ("shroud" ,shroud)))
+ (home-page "https://github.com/o-nly/emacs-shroud")
+ (synopsis "Emacs interface to the Shroud password manager")
+ (description
+ "This package provides an Emacs interface to the Shroud password manager,
+using the Buffers User Interface library. You can view, copy, and edit secrets
+from within Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-unpackaged-el
(let ((commit "f4df7f8dfea715e893b2223adda32545803f5cce")
(revision "1"))