summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-01-03 17:12:02 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-03 20:45:44 +0100
commita2aeef614c271f29be8ee445244b0d7303c0656b (patch)
tree43c4ceeb9bff0eae51a77b93372941475375277b
parent87e58e2b614b44b9b7f0c1d89d69ba7032266965 (diff)
downloadpatches-a2aeef614c271f29be8ee445244b0d7303c0656b.tar
patches-a2aeef614c271f29be8ee445244b0d7303c0656b.tar.gz
gnu: Add cl-ana.quantity.
* gnu/packages/lisp-xyz.scm (sbcl-cl-ana.quantity, cl-ana.quantity): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 50bd1a6eb1..3721822e55 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8111,3 +8111,22 @@ visualization.")
(define-public cl-ana.error-propogation
(sbcl-package->cl-source-package sbcl-cl-ana.error-propogation))
+
+(define-public sbcl-cl-ana.quantity
+ (package
+ (inherit sbcl-cl-ana-boot0)
+ (name "sbcl-cl-ana.quantity")
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cl-ana.error-propogation" ,sbcl-cl-ana.error-propogation)
+ ("cl-ana.generic-math" ,sbcl-cl-ana.generic-math)
+ ("cl-ana.list-utils" ,sbcl-cl-ana.list-utils)
+ ("cl-ana.macro-utils" ,sbcl-cl-ana.macro-utils)
+ ("cl-ana.symbol-utils" ,sbcl-cl-ana.symbol-utils)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments sbcl-cl-ana-boot0)
+ ((#:asd-file _ "") "quantity/cl-ana.quantity.asd")
+ ((#:asd-system-name _ #f) "cl-ana.quantity")))))
+
+(define-public cl-ana.quantity
+ (sbcl-package->cl-source-package sbcl-cl-ana.quantity))