summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-04-24 20:38:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-25 22:38:11 +0200
commit82bd276d604785725116976b5388b40d679e5742 (patch)
tree50bc43b2a54ed02a4bb5c6cb1d4d37eeb300abec
parent731e92f0f858508de338f54b85178daf245959e8 (diff)
downloadpatches-82bd276d604785725116976b5388b40d679e5742.tar
patches-82bd276d604785725116976b5388b40d679e5742.tar.gz
gnu: python-pastedeploy: Update to 2.1.0
* gnu/packages/python-web.scm (python-pastedeploy): Update to 2.1.0. [arguments]: Add test-target. [native-inputs]: Replace python-nose with python-pytest and python-pytest-runner.
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1d99239dbb..9f8bcdc5b5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1717,17 +1718,19 @@ and to spawn subprocesses to handle requests.")
(define-public python-pastedeploy
(package
(name "python-pastedeploy")
- (version "1.5.2")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "PasteDeploy" version))
(sha256
- (base32
- "1jz3m4hq8v6hyhfjz9425nd3nvn52cvbfipdcd72krjmla4qz1fm"))))
+ (base32 "16qsq5y6mryslmbp5pn35x4z8z3ndp5rpgl42h226879nrw9hmg7"))))
(build-system python-build-system)
+ (arguments
+ '(#:test-target "pytest"))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://pylonsproject.org/")
(synopsis
"Load, configure, and compose WSGI applications and servers")