summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <ecbrown@ericcbrown.com>2020-04-19 14:54:51 -0500
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-26 12:47:19 +0200
commit660611e5f6e5010339a7c72ef264cdb1f43a8f55 (patch)
tree81608e30b2786e5e22e86012f6194e28dda6b158
parent0745e28d66811d716d7d94d37f6663f68f751984 (diff)
downloadpatches-660611e5f6e5010339a7c72ef264cdb1f43a8f55.tar
patches-660611e5f6e5010339a7c72ef264cdb1f43a8f55.tar.gz
gnu: Add sylpheed.
* gnu/packages/mail.scm (sylpheed): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/mail.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b6c566f8cb..cb5e23bcea 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3135,3 +3136,35 @@ related tools to process winmail.dat files.")
complement or replace traditional mailing lists. Readers may read via NNTP,
Atom feeds or HTML archives.")
(license agpl3+))))
+
+(define-public sylpheed
+ (package
+ (name "sylpheed")
+ (version "3.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sylpheed.sraoss.jp/sylpheed/v3.7/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0j9y5vdzch251s264diw9clrn88dn20bqqkwfmis9l7m8vmwasqd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bogofilter" ,bogofilter)
+ ("compface" ,compface)
+ ("gnupg" ,gnupg-1)
+ ("gpgme" ,gpgme)
+ ("gtk+-2.0" ,gtk+-2)
+ ("gtkspell" ,gtkspell3)
+ ("libnsl" ,libnsl)
+ ("openldap" ,openldap)
+ ("openssl" ,openssl)))
+ (home-page "https://sylpheed.sraoss.jp/en/")
+ (synopsis "Lightweight GTK+ email client")
+ (description
+ "Sylpheed is a simple, lightweight but featureful, and easy-to-use e-mail
+client. Sylpheed provides intuitive user-interface. Sylpheed is also
+designed for keyboard-oriented operation.")
+ (license gpl2+)))