summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-26 21:33:42 +0200
committerRoel Janssen <roel@gnu.org>2020-04-26 21:34:49 +0200
commit63daca1e927136d184f41ebdd9b01923d1ee3bff (patch)
treec9d1ac2d5cf73c291537c4d898400e6152733a55
parentb58a22e5b7468906b1e223309e110109808f40ea (diff)
downloadpatches-63daca1e927136d184f41ebdd9b01923d1ee3bff.tar
patches-63daca1e927136d184f41ebdd9b01923d1ee3bff.tar.gz
gnu: Add r-snplocs-hsapiens-dbsnp144-grch37.
* gnu/packages/bioconductor.scm (r-snplocs-hsapiens-dbsnp144-grch37): New variable.
-rw-r--r--gnu/packages/bioconductor.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a27845581f..b5fa77655c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6466,6 +6466,44 @@ and parameters of which are trained on a set of aligned reads and a reference
genome sequence.")
(license license:lgpl3)))
+(define-public r-snplocs-hsapiens-dbsnp144-grch37
+ (package
+ (name "r-snplocs-hsapiens-dbsnp144-grch37")
+ (version "0.99.20")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SNPlocs.Hsapiens.dbSNP144.GRCh37"
+ version 'annotation))
+ (sha256
+ (base32
+ "1z8kx43ki1jvj7ms7pcybakcdimfwr6zpjvspkjmma97bdz093iz"))))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-iranges" ,r-iranges)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-biostrings" ,r-biostrings)))
+ (home-page
+ "https://bioconductor.org/packages/SNPlocs.Hsapiens.dbSNP144.GRCh37/")
+ (synopsis "SNP locations for Homo sapiens (dbSNP Build 144)")
+ (description "This package provides SNP locations and alleles for Homo
+sapiens extracted from NCBI dbSNP Build 144. The source data files used for
+this package were created by NCBI on May 29-30, 2015, and contain SNPs mapped
+to reference genome GRCh37.p13. Note that the GRCh37.p13 genome is a
+patched version of GRCh37. However the patch doesn't alter chromosomes 1-22,
+X, Y, MT. GRCh37 itself is the same as the hg19 genome from UCSC *except* for
+the mitochondrion chromosome. Therefore, the SNPs in this package can be
+injected in @code{BSgenome.Hsapiens.UCSC.hg19} and they will land at the
+correct position but this injection will exclude chrM (i.e. nothing will be
+injected in that sequence).")
+ (license license:artistic2.0)))
+
(define-public r-reqon
(package
(name "r-reqon")