summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-04-25 22:27:33 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-04-26 01:59:33 +0300
commit396eb9e1a968f4b210e0d00154a7d633da91307c (patch)
tree68cc5c0802b281b95ca057ab1f03901cef9b29a0
parentd558de8048f436aaa1b3ce4bcdff592b317a5639 (diff)
downloadpatches-396eb9e1a968f4b210e0d00154a7d633da91307c.tar
patches-396eb9e1a968f4b210e0d00154a7d633da91307c.tar.gz
gnu: Add sbcl-stumpwm-globalwindows.
* gnu/packages/wm.scm (sbcl-stumpwm-globalwindows): New variable.
-rw-r--r--gnu/packages/wm.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 82f11d13fa..a2c992d2c6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1732,6 +1732,36 @@ productive, customizable lisp based systems.")
rendering.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+(define-public sbcl-stumpwm-globalwindows
+ (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
+ (revision "1"))
+ (package
+ (name "sbcl-globalwindows")
+ (version (git-version "0.0.1" revision commit)) ;no upstream release
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stumpwm/stumpwm-contrib.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ahxdj9f884afpzxczx6mx7l4nwg4kw6afqaq7lwhf7lxcwylldn"))))
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/globalwindows"))))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Manipulate all windows in the current X session")
+ (description "This package provides a StumpWM module to manipulate all
+windows in the current X session.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))