summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-26 12:42:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-26 13:31:16 +0200
commit30d0f7fa8f50b3a0a56573997b5bac180691a424 (patch)
tree3e191f0afca3a9e1a1b0a8ea146abbfaf26b62f0
parent02de4b1da184eb087f6eee794842ceb795cf38fe (diff)
downloadpatches-30d0f7fa8f50b3a0a56573997b5bac180691a424.tar
patches-30d0f7fa8f50b3a0a56573997b5bac180691a424.tar.gz
gnu: nmoldyn: Adjust for Guile 3.0.
* gnu/packages/chemistry.scm (nmoldyn)[arguments]: Provide explicit destination in calls to FORMAT.
-rw-r--r--gnu/packages/chemistry.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 2b3b5d7df6..855ae2df22 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -277,16 +277,16 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
;; and Guix contains currently no free molecular viewer that
;; could be substituted.
(("PREFERENCES\\['acroread_path'\\] = ''")
- (format "PREFERENCES['acroread_path'] = '~a'"
+ (format #f "PREFERENCES['acroread_path'] = '~a'"
(which "gv")))
(("PREFERENCES\\['ncdump_path'\\] = ''")
- (format "PREFERENCES['ncdump_path'] = '~a'"
+ (format #f "PREFERENCES['ncdump_path'] = '~a'"
(which "ncdump")))
(("PREFERENCES\\['ncgen_path'\\] = ''")
- (format "PREFERENCES['ncgen_path'] = '~a'"
+ (format #f "PREFERENCES['ncgen_path'] = '~a'"
(which "ncgen3")))
(("PREFERENCES\\['task_manager_path'\\] = ''")
- (format "PREFERENCES['task_manager_path'] = '~a'"
+ (format #f "PREFERENCES['task_manager_path'] = '~a'"
(which "task_manager")))
;; Show documentation as PDF
(("PREFERENCES\\['documentation_style'\\] = 'html'")