summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-04-24 00:47:44 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-26 12:15:09 +0200
commit0bf66cbb72937f1bc084a1b84d85864761056f40 (patch)
treecd0de93ba868ae1d1ef2dd3fc672dd01d1bafd89
parentbb85018ceb9bd1b75c7ccb4d5de959e879a2b113 (diff)
downloadpatches-0bf66cbb72937f1bc084a1b84d85864761056f40.tar
patches-0bf66cbb72937f1bc084a1b84d85864761056f40.tar.gz
gnu: Add python-osc.
* gnu/packages/python-xyz.scm (python-osc): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a7bbcc299..9460a59e31 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
-;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019, 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -19544,3 +19544,23 @@ a set of pluggable tools to help the programmer in various ways. Some
example tools are source structure, project manager, interactive help,
workspace...")
(license license:bsd-2)))
+
+(define-public python-osc
+ (package
+ (name "python-osc")
+ (version "1.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-osc" version))
+ (sha256
+ (base32
+ "0cnh0z5lnng7fh48nmfaqqn8j25k13gkd4rhxd3m6sjqiix9s3vn"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/attwad/python-osc")
+ (synopsis "Open Sound Control server and client implementations")
+ (description
+ "@code{python-osc} is a pure Python library with no external
+dependencies. It implements the @uref{http://opensoundcontrol.org/spec-1_0,
+Open Sound Control 1.0} specification.")
+ (license license:unlicense)))