summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-26 05:50:47 -0400
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-26 12:25:59 +0200
commit0745e28d66811d716d7d94d37f6663f68f751984 (patch)
treefa6352ce145bd265c0c455a51071c3008c7ad4b8
parent0bf66cbb72937f1bc084a1b84d85864761056f40 (diff)
downloadpatches-0745e28d66811d716d7d94d37f6663f68f751984.tar
patches-0745e28d66811d716d7d94d37f6663f68f751984.tar.gz
gnu: Add xarchiver.
* gnu/packages/compression (xarchiver): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/compression.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e9ef302bcd..33801d201d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -50,6 +50,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
@@ -63,6 +64,10 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages file)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -70,6 +75,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages xml)
#:use-module (ice-9 match)
#:use-module ((srfi srfi-1) #:select (last)))
@@ -2094,3 +2100,34 @@ programs that used to be the de facto UNIX standard for compressing and
uncompressing files. These programs implement a fast, simple Lempel-Ziv (LZW)
file compression algorithm.")
(license license:gpl2+)))
+
+(define-public xarchiver
+ (package
+ (name "xarchiver")
+ (version "0.5.4.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ib/xarchiver.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iklwgykgymrwcc5p1cdbh91v0ih1m58s3w9ndl5kyd44bwlb7px"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("intltool" ,intltool)
+ ("libxslt" ,libxslt)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+ ("gtk+" ,gtk+)))
+ (home-page "https://github.com/ib/xarchiver")
+ (synopsis "Graphical front-end for archive operations")
+ (description "Xarchiver is a front-end to various command line archiving
+tools. It uses GTK+ tool-kit and is designed to be desktop-environment
+independent. Supported formats are 7z, ARJ, bzip2, gzip, LHA, lzma, lzop,
+RAR, RPM, DEB, tar, and ZIP. It cannot perform functions for archives, whose
+archiver is not installed.")
+ (license license:gpl2+)))