summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-04-25 15:53:52 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-04-26 15:14:46 +0530
commit018114baa75c1986a1a971f5e48e6b722c7741ba (patch)
treea93779224112be533729499eefd142110b3a6d70
parent796b387bc28c2ca5d116fced9247eb832e168d16 (diff)
downloadpatches-018114baa75c1986a1a971f5e48e6b722c7741ba.tar
patches-018114baa75c1986a1a971f5e48e6b722c7741ba.tar.gz
gnu: maradns: Fix cross compilation.
* gnu/packages/dns.scm (maradns)[arguments]: Build make_32bit_tables for the host.
-rw-r--r--gnu/packages/dns.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 80ed1f0b49..86569b5493 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages groff)
#:use-module (gnu packages groff)
@@ -979,7 +980,15 @@ known public suffixes.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _
+ (lambda* (#:key native-inputs target #:allow-other-keys)
+ ;; make_32bit_tables generates a header file that is used during
+ ;; compilation. Hence, during cross compilation, it should be
+ ;; built for the host system.
+ (when target
+ (substitute* "rng/Makefile"
+ (("\\$\\(CC\\) -o make_32bit_tables")
+ (string-append (assoc-ref native-inputs "gcc")
+ "/bin/gcc -o make_32bit_tables"))))
(invoke "./configure")))
(add-before 'install 'create-install-directories
(lambda* (#:key outputs #:allow-other-keys)