summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-24 01:27:55 +0530
committerRicardo Wurmus <rekado@elephly.net>2020-04-24 15:43:01 +0200
commitfe14871eddf656d574b2634bcf1093614d45d70c (patch)
tree07feaaff443462fdfb8d7cb50591fec1973b66f9
parentba07c7f067a128970e604064b13e3a2a0536934b (diff)
downloadpatches-fe14871eddf656d574b2634bcf1093614d45d70c.tar
patches-fe14871eddf656d574b2634bcf1093614d45d70c.tar.gz
gnu: Add r-awsmethods.
* gnu/packages/cran.scm (r-awsmethods): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index caf3830cad..12dd6a3e26 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21191,3 +21191,25 @@ is the number of data in the tail. The third class is motivated by graphical
inspection. In addition, a sequential testing procedure for GPD-GoF-tests
is also implemented here.")
(license license:gpl3)))
+
+(define-public r-awsmethods
+ (package
+ (name "r-awsmethods")
+ (version "1.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "awsMethods" version))
+ (sha256
+ (base32
+ "0hbmrcpdyg15zg4rysscsmxpxlpy0dkxx2aa63qibq7l1k14v4sh"))))
+ (properties
+ `((upstream-name . "awsMethods")))
+ (build-system r-build-system)
+ (home-page "http://www.wias-berlin.de/software/imaging/")
+ (synopsis "Class and methods definitions")
+ (description
+ "This package defines the generic method @code{extract} and provides
+@code{openMP} support as needed in several packages like
+@code{aws}, @code{adimpro}, @code{fmri}, and @code{dwi}.")
+ (license license:gpl2+)))