summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-24 01:23:25 +0530
committerRicardo Wurmus <rekado@elephly.net>2020-04-24 15:40:10 +0200
commitba07c7f067a128970e604064b13e3a2a0536934b (patch)
tree67f903f03e8c4a9df3764debcd2264a92b30aa43
parenta1d369f139b4788fd66ed0129cb43c205248dc56 (diff)
downloadpatches-ba07c7f067a128970e604064b13e3a2a0536934b.tar
patches-ba07c7f067a128970e604064b13e3a2a0536934b.tar.gz
gnu: Add r-tea.
* gnu/packages/cran.scm (r-tea): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..caf3830cad 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,32 @@ evaluated interactively.")
Bayes factors, posterior model probabilities, and normalizing constants in
general, via different versions of bridge sampling.")
(license license:gpl2+)))
+
+(define-public r-tea
+ (package
+ (name "r-tea")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tea" version))
+ (sha256
+ (base32
+ "0ql7lrxk0ihm49kqsvz79ig8i54rwiy9nxav4v9hy72j9kj5bgjn"))))
+ (properties
+ `((upstream-name . "tea")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)))
+ (home-page "https://cran.r-project.org/web/packages/tea/")
+ (synopsis "Threshold estimation approaches")
+ (description
+ "This package provide different approaches for selecting the threshold
+in generalized Pareto distributions. Most of them are based on minimizing the
+AMSE-criterion or atleast by reducing the bias of the assumed GPD-model.
+Others are heuristically motivated by searching for stable sample paths, i.e.
+a nearly constant region of the tail index estimator with respect to k, which
+is the number of data in the tail. The third class is motivated by graphical
+inspection. In addition, a sequential testing procedure for GPD-GoF-tests
+is also implemented here.")
+ (license license:gpl3)))