summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-24 01:58:15 +0530
committerRicardo Wurmus <rekado@elephly.net>2020-04-24 15:53:21 +0200
commit53269e6971025da0d8eeef4a7d54b92b89649ff3 (patch)
treeb125e031abc624a137e34aee86bee957e8fef530
parent3a8ee5ef4212f072f53a32302c4f57e7ec55da48 (diff)
downloadpatches-53269e6971025da0d8eeef4a7d54b92b89649ff3.tar
patches-53269e6971025da0d8eeef4a7d54b92b89649ff3.tar.gz
gnu: Add r-dcv.
* gnu/packages/cran.scm (r-dcv): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a2a5da62a7..aeba263843 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21326,3 +21326,28 @@ under the coarsened at random assumption.")
Analysis and Modelling, including Exploratory Spatio-Temporal Analysis and
Inferred Spatio-Temporal Modelling.")
(license license:gpl2+)))
+
+(define-public r-dcv
+ (package
+ (name "r-dcv")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dcv" version))
+ (sha256
+ (base32
+ "12c716x8dnxnqksibpmyysqp2axggvy9dpd55s9bhnsvqvi6dshj"))))
+ (properties
+ `((upstream-name . "dcv")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lmtest" ,r-lmtest)))
+ (home-page "https://cran.r-project.org/web/packages/dcv/")
+ (synopsis "Conventional cross-validation statistics for climate-growth model")
+ (description
+ "This package performs several conventional cross-validation statistical
+methods for climate-growth model in the climate reconstruction from tree
+rings, including Sign Test statistic, Reduction of Error statistic, Product
+Mean Test, Durbin-Watson statistic etc.")
+ (license license:gpl2)))